Limited functionality of Support Tools

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Aug 28, 2024 - 13:38 BST

Identified

Due to a technical issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted Aug 28, 2024 - 13:13 BST
This incident affected: Customer Service (Support Tool).