Greater hold time in our Hotline
Incident Report for ionos.co.uk
Resolved
This incident has been resolved.
Posted Dec 20, 2021 - 09:37 GMT
Update
Due to a technical disruption there may currently be an increased call volume to our hotlines. Waiting times may therefore be longer. Feel free and send us your request via email to support@ionos.co.uk and we will get back to you as soon as possible.
Posted Dec 17, 2021 - 10:06 GMT
Identified
Due to this technical disruption there may currently be an increased call volume to our support line. Waiting times may therefore be longer.
Posted Dec 16, 2021 - 13:21 GMT
This incident affected: Customer Service (Support Tool).