Sending e-mails to Microsoft freemail accounts occasionally not possible
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Mar 13, 2020 - 12:00 GMT
Identified
Some customers may be experiencing issues sending E-mails to Microsoft's Free Mail Services (Hotmail,parts of Outlook.com).
Posted Mar 03, 2020 - 11:42 GMT
This incident affected: Mail System and Delivery (Sending Emails).