Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Jul 12, 2022 - 16:46 BST
Update
We have found the cause for the disruption and are working on resolving it.
Posted Jul 12, 2022 - 15:31 BST
Update
We are still working on resolving the technical issue. Thank you for your patience.
Posted Jul 12, 2022 - 14:28 BST
Identified
Some customers may face issues while using their Microsoft Exchange 2019.
Posted Jul 12, 2022 - 14:00 BST
This incident affected: Email (Microsoft Exchange).