Incident Report for Web Hosting

Incident Report for ionos.co.uk

Resolved

The systems are stable and all services are functioning normally again.
Posted Sep 24, 2026 - 14:46 BST

Update

We have successfully minimised the disruption and are working to completely resolve it as soon as possible.
Posted Sep 24, 2026 - 13:07 BST

Identified

Some customers may be experiencing issues when accessing the Webspace Explorer
Posted Sep 24, 2026 - 11:38 BST
This incident affected: Hosting (Web Hosting).