Greater hold time in our Hotline
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Nov 12, 2019 - 14:53 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 12, 2019 - 14:17 GMT
Identified
Due to a techncial issue with our Support Tools, our Customer Service Team are not able to answer questions related to your account.
Posted Nov 12, 2019 - 14:16 GMT
This incident affected: Customer Service (Support Tool).