Limited functionality of product Email Marketing
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted May 13, 2020 - 15:35 BST
Identified
Some customers may face issues while using their Email Marketing.
Posted May 13, 2020 - 13:32 BST
This incident affected: Online Marketing (E-Mail Marketing).