Incident report with creating mailboxes
Incident Report for ionos.co.uk
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 13:19 BST
Identified
Some customers may be experiencing issues creating mailboxes.
Posted Oct 21, 2020 - 11:25 BST
This incident affected: Control Panel.