Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Mar 03, 2020 - 13:13 GMT
Identified
Some customers may experience issues while using their Backup Console
Posted Mar 03, 2020 - 08:10 GMT
This incident affected: Server & Cloud (Cloud Server).