Incident Report
Incident Report for ionos.co.uk
Resolved
The systems are stable and all services are functioning normally again.
Posted about 1 month ago. Apr 22, 2019 - 18:33 BST
Identified
Due to a technical issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted about 1 month ago. Apr 22, 2019 - 17:13 BST
This incident affected: Customer Service (Support Tool).