Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Dec 08, 2021 - 12:08 GMT
Identified
During this time, configurations in some areas of your control panel may be limited.
Posted Dec 08, 2021 - 11:47 GMT
This incident affected: Contract Management (Billing Service).