Cannot create email addresses
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Jan 14, 2021 - 13:12 GMT
Identified
Some customers may have problems creating email addresses.
Posted Jan 14, 2021 - 11:41 GMT
This incident affected: IONOS (IONOS Control Panel).