Upcoming HiDrive Maintenance
Incident Report for ionos.co.uk
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 02, 2018 - 09:50 GMT
Investigating
We will be performing maintenance on our HiDrive product between 2:00 a.m. to 4:00 a.m. on 2 November 2018. During this time, you may experience connectivity issues with your HiDrive accounts, so please plan accordingly.

We sincerely apologise for any inconvenience this may cause you.
Posted 6 months ago. Nov 01, 2018 - 11:17 GMT
This incident affected: Email & Office (HiDrive).