Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Mar 24, 2020 - 11:19 GMT
Identified
Access to E-Mail & Office in the Control Panel may be temporarily restricted.
Posted Mar 24, 2020 - 10:35 GMT
This incident affected: Control Panel.