Support Hotline cannot be reached
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Oct 29, 2020 - 13:11 GMT
Identified
Due to a technical disruption, the Support hotline is temporarily unavailable. Please call us back later or send us an E-mail to support@ionos.co.uk
Posted Oct 29, 2020 - 12:26 GMT
This incident affected: Customer Service (Customer Hotline).