Incident Report for MyWebsite NOW
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Feb 28, 2024 - 18:31 GMT
Identified
Some customers may be experiencing issues accessing their websites.
Posted Feb 28, 2024 - 17:32 GMT
This incident affected: Website Builder (MyWebsite NOW).