Delay in receiving E-mails
Incident Report for ionos.co.uk
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 11:22 GMT
Identified
Some customers may be experiencing delays in receiving E-mails. Our technicians are currently working on resolving this issue.
Posted Jan 13, 2021 - 10:31 GMT
This incident affected: Mail System and Delivery (Receiving Emails).