Technical issues in our email systems
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.. We apologise for the inconvenience caused and thank you for your patience.
Posted May 07, 2024 - 10:22 BST
Investigating
Currently, there are issues in our email systems. Access to webmail and mail client may not be possible.
Posted May 07, 2024 - 09:47 BST
This incident affected: Email (Webmail).