Incident Report for E-mail and Office
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Our apologies for the inconvenience caused.
Posted Jan 09, 2025 - 22:28 GMT
Identified
Access to E-Mail & Office in the Control Panel may be temporarily restricted.
Posted Jan 09, 2025 - 22:17 GMT
This incident affected: IONOS (IONOS Control Panel).