Incident Report for Cloud Backup
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted Nov 08, 2019 - 13:57 GMT
Identified
Some customers may experience issues while using their Cloud Backup.
Posted Nov 07, 2019 - 13:45 GMT
This incident affected: Servers (Cloud Server).