Domain order and DNS technical disruption
Incident Report for ionos.co.uk
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 13:18 BST
Update
We are experiencing technical issues with placing orders on our website.
Posted Oct 14, 2020 - 11:43 BST
Identified
Due to a technical disruption some Customers may experience delays in domain configuration.
Posted Oct 14, 2020 - 11:35 BST
This incident affected: Domains (DNS) and Contract Management (Order Page).