Incident Report for Support Tool
Incident Report for ionos.co.uk
Resolved
Thank you for your patience and understanding.
Posted Mar 03, 2021 - 11:21 GMT
Identified
Due to a technical issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted Mar 03, 2021 - 10:18 GMT
This incident affected: Customer Service (Support Tool).