Disruption in logging into the Webmail
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 3 months ago. Jul 23, 2019 - 16:50 BST
Identified
We have received reports that some of our customers are experiencing issues when attempting to log into Webmail
Posted 3 months ago. Jul 23, 2019 - 16:27 BST
This incident affected: Email & Office (Webmail).