Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 3 months ago. Jul 08, 2019 - 12:58 BST
Update
Due to a technical disruption, recent purchases of products may be delayed during setup.
Posted 3 months ago. Jul 08, 2019 - 09:27 BST
Update
We are experiencing technical issues with placing orders.
We are still working on resolving the technical issue. Thank you for your patience.
Posted 3 months ago. Jul 08, 2019 - 07:31 BST
Identified
We are experiencing an issue with our Contract Tool. In urgent cases please contact Customer Care via 0333 336 5780 to finalize the cancellation.

We are experiencing technical issues with placing orders.
Posted 3 months ago. Jul 08, 2019 - 07:02 BST
This incident affected: Contract Management (Order Page, Cancellation Service).