Access to E-Mail & Office in the Control Panel may be temporarily restricted.
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted 3 months ago. Jun 03, 2019 - 13:48 BST
Identified
Access to E-Mail & Office in the Control Panel may be temporarily restricted. We will post an update as soon as new information becomes available.
Posted 3 months ago. Jun 03, 2019 - 13:35 BST
This incident affected: Control Panel.