Support Hotline cannot be reached
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 3 months ago. Jun 19, 2019 - 07:53 BST
Identified
An outage in one of our main offices is impacting our support line. You may experience a greater hold time than usual. We apologise for any inconvenience during these brief technical difficulties and appreciate your patience and understanding. We will continue to post updates as we make progress on these issues.

Please contact our support team via e-mail at support@ionos.co.uk
Posted 3 months ago. Jun 19, 2019 - 07:30 BST
This incident affected: Customer Service (Customer Hotline).