Email address creation may not be possible
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Apr 29, 2021 - 20:55 BST
Identified
Some customers may be experiencing issues creating email address
Posted Apr 29, 2021 - 20:16 BST
This incident affected: IONOS (IONOS Control Panel).