Incident Report
Incident Report for ionos.co.uk
Resolved
The systems are stable and all services are functioning normally again.
Posted Jan 10, 2021 - 15:54 GMT
Identified
Some customers may be experiencing issues receiving E-mails.
Posted Jan 10, 2021 - 09:44 GMT
This incident affected: Mail System and Delivery (Receiving Emails).