Upcoming HiDrive Maintenance
Incident Report for ionos.co.uk
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 07, 2018 - 06:24 GMT
Monitoring
We will be performing maintenance on our HiDrive product between 1:00 a.m. to 2:00 a.m. on 7 November 2018. During this time, you may experience connectivity issues with your HiDrive accounts, so please plan accordingly.

We sincerely apologise for any inconvenience this may cause you.
Posted 8 months ago. Nov 06, 2018 - 14:33 GMT
This incident affected: Email & Office (HiDrive).