Disruption in logging into the Webmail
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 16 days ago. Sep 28, 2019 - 13:50 BST
Identified
We have received reports that some of our customers may be experiencing issues when attempting to log into Webmail
Posted 16 days ago. Sep 28, 2019 - 13:29 BST
This incident affected: Email & Office (Webmail).