Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Mar 03, 2020 - 07:05 GMT
Identified
Some customers may experience issues while using their Backup Console
Posted Mar 02, 2020 - 16:55 GMT
This incident affected: Server & Cloud (Cloud Server).