Incident Report for Online Accounting
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 6 months ago. Apr 19, 2019 - 13:14 BST
Identified
Some customers are experiencing issues while using their Online Accounting.
Posted 6 months ago. Apr 19, 2019 - 12:30 BST
This incident affected: Email & Office (Online Accounting).