Greater hold time in our Hotline
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 3 months ago. Mar 03, 2019 - 08:19 GMT
Identified
Due to a techncial issue with our Support Tools, our Customer Service Team are not be able to answer questions related to your account.
Posted 3 months ago. Mar 03, 2019 - 07:07 GMT
This incident affected: Customer Service (Support Tool).