Disruption when logging into Microsoft Exchange 2013
Incident Report for ionos.co.uk
Resolved
The disruption that affected Microsoft Exchange 2013 has been resolved.
Posted 3 months ago. Mar 04, 2019 - 20:35 GMT
Identified
Some customers may experiencing login problems when trying to access Microsoft Exchange 2013.
Posted 3 months ago. Mar 04, 2019 - 18:21 GMT