Incident Report for Customer Service Support Tool
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Oct 05, 2020 - 10:31 BST
Identified
Due to a technical issue with our Support Tools, our Customer Service Team may not able to answer questions related to your account.
Posted Oct 05, 2020 - 10:25 BST
This incident affected: Customer Service (Support Tool).