Incident Report
Incident Report for ionos.co.uk
Resolved
The systems are stable and all services are functioning normally again.
Posted 3 months ago. Apr 08, 2019 - 12:23 BST
Identified
Due to a techncial issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted 3 months ago. Apr 08, 2019 - 11:01 BST
This incident affected: Customer Service (Support Tool).